Below are two tables showing the two problem classes that prevent installation of foreign architecture binaries

We try to install all binary packages from a dummy architecture generated from amd64 (called armhf here) on amd64.

A machine parsable version can be retrieved in dose yaml format

Hover over a package name with your cursor for architecture and version information. Hovering over the arrows in the depchain columns will show the dependency that led from one package in the chain to the next.

src:gtk-sharp3

Top 10 summary

The following is a summary of the full "missing" and "conflict" tables below. It only shows the first and last columns of the full tables and only displays the top 10 rows.

Missing

# of packages per missingUnsatisfied dependency
121libmono-corlib4.5-cil:armhf (>= 5.18.0.240)
111cli-common:armhf (>= 0.5.1)
22libmono-system4.0-cil:armhf (>= 5.18.0.240)
7libmono-system-xml4.0-cil:armhf (>= 4.6.1.3)
7mono-gac:armhf (= 6.8.0.105+dfsg-3)
6libxml-namespacesupport-perl:armhf
6libxml-sax-perl:armhf
6perlapi-5.32.0:armhf
3libmono-system-drawing4.0-cil:armhf (>= 5.12.0.309)
3perl-base:armhf (= 5.32.1-4)

missing

The packages in the third column cannot satisfy their (possibly transitive) dependencies because of the unsatisfied dependency in the last column. This is mostly because the binary package providing the dependency in the last column is Multi-Arch:no. Some of these packages need to be Multi-Arch:foreign instead. In some other cases, Build-Depends can be annotated with :native. The depchains column shows the dependency chain(s) from the packages in the third column to the unsatisfied dependency in the last column. The "(*)" placeholder in the depchains column represents any package in the third column. Hovering over the arrows in the depchains column with your cursor will show the dependency that led from one package in the chain to the next.

The output is first grouped by the shared unsatisfied dependency (last column) and then by shared dependency chain (fourth column). The groups are sorted by the number of packages missing the dependency in the last column. Within each group, the output is sorted by the number of packages sharing the same dependency chain.

# of packages per missing# of packages per depchainpackages with missing (possibly transitive) dependenciesDepchainsUnsatisfied dependency
121 24cairo-dock-dbus-plug-in-interface-mono cowbell gbrainy gnome-subtitles gtk-sharp2-gapi gtk-sharp3-gapi libappindicator3-0.1-cil libatk3.0-cil libayatana-appindicator0.1-cil libcairo1.10-cil libgdcm-cil libgdk3.0-cil libgio3.0-cil libglade2.0-cil libglib2.0-cil libglib3.0-cil libgpod-cil (O: #867215) libgtk-dotnet3.0-cil libgtk2.0-cil libgtk3.0-cil libmono-fuse-cil libpango3.0-cil libsbml5-cil libvtkgdcm-cil(*) libmono-corlib4.5-cil:armhf (>= 5.18.0.240)
7gbrainy libappindicator3-0.1-cil libatk3.0-cil libgio3.0-cil libpango3.0-cil libsoup2.4-cil libwebkit2-sharp-4.0-cil(*)libglib3.0-cil
6gbrainy gnome-subtitles libgdk3.0-cil libgtk-dotnet3.0-cil libgtk3.0-cil libpango3.0-cil(*)libcairo1.10-cil
5gbrainy gnome-subtitles libappindicator3-0.1-cil libgtk-dotnet3.0-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibatk3.0-cil
5gbrainy gnome-subtitles libappindicator3-0.1-cil libgtk-dotnet3.0-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cil
4gbrainy gnome-subtitles libgtk-dotnet3.0-cil libgtk3.0-cil(*)libgdk3.0-cil
4gbrainy gnome-subtitles libgdk3.0-cil libgtk-dotnet3.0-cil(*)libpango3.0-cil
3gbrainy libgtk-dotnet3.0-cil libgtk3.0-cil(*)libgdk3.0-cillibgio3.0-cil
2gnome-subtitles libgdk3.0-cil(*)libgio3.0-cillibglib3.0-cil
2gnome-subtitles libgdk3.0-cil(*)libgio3.0-cil
2gtk-sharp3 libgtk3.0-cil-dev(*)libgio3.0-cil-devlibgio3.0-cillibglib3.0-cil
2gtk-sharp3 libgtk3.0-cil-dev(*)libgio3.0-cil-devlibgio3.0-cil
2libappindicator3-0.1-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibcairo1.10-cil
2libappindicator3-0.1-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibgdk3.0-cillibgio3.0-cil
2libappindicator3-0.1-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibgdk3.0-cil
2libappindicator3-0.1-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibgdk3.0-cillibpango3.0-cil
2libgtk-dotnet3.0-cil libgtk3.0-cil(*)libgdk3.0-cillibgio3.0-cillibglib3.0-cil
1gtk-sharp3(*)gtk-sharp3-gapi
1gtk-sharp3(*)libgtk3.0-cil-devlibatk3.0-cil
1gtk-sharp3(*)libgtk3.0-cil-devlibcairo1.10-cil
1gtk-sharp3(*)libgtk3.0-cil-devlibgtk3.0-cillibgdk3.0-cil
1gtk-sharp3(*)libgtk3.0-cil-devlibgtk3.0-cillibgdk3.0-cillibpango3.0-cil
1gtk-sharp3(*)libgtk3.0-cil-devlibgtk3.0-cil
1gtk-sharp3-gapi(*)libglib3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibglib3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibatk3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibcairo1.10-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibgdk3.0-cillibgio3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibgdk3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibgdk3.0-cillibpango3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cillibcairo1.10-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cillibgio3.0-cillibglib3.0-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cillibgio3.0-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cillibpango3.0-cil
1libgio3.0-cil-dev(*)libgio3.0-cillibglib3.0-cil
1libgio3.0-cil-dev(*)libgio3.0-cil
1libglib3.0-cil-dev(*)libglib3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibcairo1.10-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgdk3.0-cillibgio3.0-cillibglib3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgdk3.0-cillibgio3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgdk3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgtk3.0-cillibatk3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgtk3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibpango3.0-cil
1libgtk3.0-cil(*)libatk3.0-cil
1libgtk3.0-cil(*)libgdk3.0-cillibpango3.0-cil
1libgtk3.0-cil-dev(*)libatk3.0-cil
1libgtk3.0-cil-dev(*)libcairo1.10-cil
1libgtk3.0-cil-dev(*)libgtk3.0-cillibgdk3.0-cil
1libgtk3.0-cil-dev(*)libgtk3.0-cillibgdk3.0-cillibpango3.0-cil
1libgtk3.0-cil-dev(*)libgtk3.0-cil
1libsoup2.4-cil-dev(*)libsoup2.4-cillibglib3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibglib3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibatk3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibcairo1.10-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibgdk3.0-cillibgio3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibgdk3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibgdk3.0-cillibpango3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cil
111 15libappindicator3-0.1-cil libatk3.0-cil libayatana-appindicator0.1-cil libcairo1.10-cil libgdcm-cil libgdk3.0-cil libgio3.0-cil libglib3.0-cil libgtk-dotnet3.0-cil libgtk3.0-cil libpango3.0-cil libsoup2.4-cil libvirtuoso5.5-cil libvtkgdcm-cil libwebkit2-sharp-4.0-cil(*) cli-common:armhf (>= 0.5.1)
7gbrainy libappindicator3-0.1-cil libatk3.0-cil libgio3.0-cil libpango3.0-cil libsoup2.4-cil libwebkit2-sharp-4.0-cil(*)libglib3.0-cil
6gbrainy gnome-subtitles libgdk3.0-cil libgtk-dotnet3.0-cil libgtk3.0-cil libpango3.0-cil(*)libcairo1.10-cil
5gbrainy gnome-subtitles libappindicator3-0.1-cil libgtk-dotnet3.0-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cil
5gbrainy gnome-subtitles libappindicator3-0.1-cil libgtk-dotnet3.0-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibatk3.0-cil
4gbrainy gnome-subtitles libgtk-dotnet3.0-cil libgtk3.0-cil(*)libgdk3.0-cil
4gbrainy gnome-subtitles libgdk3.0-cil libgtk-dotnet3.0-cil(*)libpango3.0-cil
3gbrainy libgtk-dotnet3.0-cil libgtk3.0-cil(*)libgdk3.0-cillibgio3.0-cil
2gnome-subtitles libgdk3.0-cil(*)libgio3.0-cil
2gnome-subtitles libgdk3.0-cil(*)libgio3.0-cillibglib3.0-cil
2gtk-sharp3 libgtk3.0-cil-dev(*)libgio3.0-cil-devlibgio3.0-cil
2gtk-sharp3 libgtk3.0-cil-dev(*)libgio3.0-cil-devlibgio3.0-cillibglib3.0-cil
2libappindicator3-0.1-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibcairo1.10-cil
2libappindicator3-0.1-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibgdk3.0-cil
2libappindicator3-0.1-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibgdk3.0-cillibgio3.0-cil
2libappindicator3-0.1-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibgdk3.0-cillibpango3.0-cil
2libgtk-dotnet3.0-cil libgtk3.0-cil(*)libgdk3.0-cillibgio3.0-cillibglib3.0-cil
1gtk-sharp3(*)libgtk3.0-cil-devlibatk3.0-cil
1gtk-sharp3(*)libgtk3.0-cil-devlibcairo1.10-cil
1gtk-sharp3(*)libgtk3.0-cil-devlibgtk3.0-cil
1gtk-sharp3(*)libgtk3.0-cil-devlibgtk3.0-cillibgdk3.0-cil
1gtk-sharp3(*)libgtk3.0-cil-devlibgtk3.0-cillibgdk3.0-cillibpango3.0-cil
1gtk-sharp3-gapi(*)libglib3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibglib3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibatk3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibcairo1.10-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibgdk3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibgdk3.0-cillibgio3.0-cil
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibgdk3.0-cillibpango3.0-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cillibcairo1.10-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cillibgio3.0-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cillibgio3.0-cillibglib3.0-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cillibpango3.0-cil
1libgio3.0-cil-dev(*)libgio3.0-cil
1libgio3.0-cil-dev(*)libgio3.0-cillibglib3.0-cil
1libglib3.0-cil-dev(*)libglib3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibcairo1.10-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgdk3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgdk3.0-cillibgio3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgdk3.0-cillibgio3.0-cillibglib3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgtk3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgtk3.0-cillibatk3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibpango3.0-cil
1libgtk3.0-cil(*)libatk3.0-cil
1libgtk3.0-cil(*)libgdk3.0-cillibpango3.0-cil
1libgtk3.0-cil-dev(*)libatk3.0-cil
1libgtk3.0-cil-dev(*)libcairo1.10-cil
1libgtk3.0-cil-dev(*)libgtk3.0-cil
1libgtk3.0-cil-dev(*)libgtk3.0-cillibgdk3.0-cil
1libgtk3.0-cil-dev(*)libgtk3.0-cillibgdk3.0-cillibpango3.0-cil
1libsoup2.4-cil-dev(*)libsoup2.4-cillibglib3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibglib3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibatk3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibcairo1.10-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibgdk3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibgdk3.0-cillibgio3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibgdk3.0-cillibpango3.0-cil
22 7cowbell gbrainy gnome-subtitles gtk-sharp3-gapi libgio3.0-cil libglib2.0-cil libmono-fuse-cil(*) libmono-system4.0-cil:armhf (>= 5.18.0.240)
3gbrainy libgtk-dotnet3.0-cil libgtk3.0-cil(*)libgdk3.0-cillibgio3.0-cil
2gnome-subtitles libgdk3.0-cil(*)libgio3.0-cil
2gtk-sharp3 libgtk3.0-cil-dev(*)libgio3.0-cil-devlibgio3.0-cil
2libappindicator3-0.1-cil libwebkit2-sharp-4.0-cil(*)libgtk3.0-cillibgdk3.0-cillibgio3.0-cil
1gtk-sharp3(*)gtk-sharp3-gapi
1libappindicator3-0.1-cil-dev(*)libappindicator3-0.1-cillibgtk3.0-cillibgdk3.0-cillibgio3.0-cil
1libgdk3.0-cil-dev(*)libgdk3.0-cillibgio3.0-cil
1libgio3.0-cil-dev(*)libgio3.0-cil
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cillibgdk3.0-cillibgio3.0-cil
1libwebkit2-sharp-4.0-cil-dev(*)libwebkit2-sharp-4.0-cillibgtk3.0-cillibgdk3.0-cillibgio3.0-cil
7 6cowbell gbrainy gtk-sharp2-gapi gtk-sharp3-gapi quickroute-gps tangerine(*) libmono-system-xml4.0-cil:armhf (>= 4.6.1.3)
1gtk-sharp3(*)gtk-sharp3-gapi
7 6cowbell gbrainy gtk-sharp2-gapi gtk-sharp3-gapi quickroute-gps tangerine(*)mono-runtimemono-runtime-sgenmono-runtime-common mono-gac:armhf (= 6.8.0.105+dfsg-3)
1gtk-sharp3(*)gtk-sharp3-gapimono-runtimemono-runtime-sgenmono-runtime-common
6 5gtk-sharp2-gapi gtk-sharp3-gapi libxml-libxslt-perl os-autoinst sympa(*)libxml-libxml-perl libxml-namespacesupport-perl:armhf
1gtk-sharp3(*)gtk-sharp3-gapilibxml-libxml-perl
6 5gtk-sharp2-gapi gtk-sharp3-gapi libxml-libxslt-perl os-autoinst sympa(*)libxml-libxml-perl libxml-sax-perl:armhf
1gtk-sharp3(*)gtk-sharp3-gapilibxml-libxml-perl
6 5gtk-sharp2-gapi gtk-sharp3-gapi libxml-libxslt-perl os-autoinst sympa(*)libxml-libxml-perl perlapi-5.32.0:armhf
1gtk-sharp3(*)gtk-sharp3-gapilibxml-libxml-perl
3 2libgtk-dotnet3.0-cil libgtk2.0-cil(*) libmono-system-drawing4.0-cil:armhf (>= 5.12.0.309)
1libgtk-dotnet3.0-cil-dev(*)libgtk-dotnet3.0-cil
3 2gtk-sharp2-gapi gtk-sharp3-gapi(*)libxml-libxml-perlperl perl-base:armhf (= 5.32.1-4)
1gtk-sharp3(*)gtk-sharp3-gapilibxml-libxml-perlperl
1 1gtk-sharp3(*) gtk-sharp3-examples:armhf (= 2.99.3-4)
1 1gtk-sharp3(*) monodoc-gtk3.0-manual:armhf (= 2.99.3-4)

generated: 20210531T000000Z


The JSON data used to generate these pages was computed using botch, the bootstrap/build ordering tool chain. The source code of botch can be redistributed under the terms of the LGPL3+ with an OCaml linking exception. The source code can be retrieved from https://gitlab.mister-muffin.de/debian-bootstrap/botch

The html pages were generated by code which can be retrieved from https://gitlab.mister-muffin.de/debian-bootstrap/bootstrap_debian_net and which can be redistributed under the terms of the AGPL3+

For questions and bugreports please contact j [dot] schauer [at] email [dot] de.