Below are two tables showing the two problem classes that prevent installation of foreign architecture binaries

We try to install all binary packages from a dummy architecture generated from amd64 (called armhf here) on amd64.

A machine parsable version can be retrieved in dose yaml format

Hover over a package name with your cursor for architecture and version information. Hovering over the arrows in the depchain columns will show the dependency that led from one package in the chain to the next.

src:gtk-sharp2

Top 10 summary

The following is a summary of the full "missing" and "conflict" tables below. It only shows the first and last columns of the full tables and only displays the top 10 rows.

Missing

# of packages per missingUnsatisfied dependency
52libmono-corlib4.5-cil:armhf (>= 5.18.0.240)
31cli-common:armhf (>= 0.5.6)
21libmono-system4.0-cil:armhf (>= 5.18.0.240)
12libmono-system-drawing4.0-cil:armhf (>= 5.12.0.309)
11libmono-cairo4.0-cil:armhf (>= 5.16.0.220)
6libmono-system-xml4.0-cil:armhf (>= 4.6.1.3)
6mono-gac:armhf (= 6.8.0.105+dfsg-3)
5libxml-namespacesupport-perl:armhf
5libxml-sax-perl:armhf
5perlapi-5.32.0:armhf

missing

The packages in the third column cannot satisfy their (possibly transitive) dependencies because of the unsatisfied dependency in the last column. This is mostly because the binary package providing the dependency in the last column is Multi-Arch:no. Some of these packages need to be Multi-Arch:foreign instead. In some other cases, Build-Depends can be annotated with :native. The depchains column shows the dependency chain(s) from the packages in the third column to the unsatisfied dependency in the last column. The "(*)" placeholder in the depchains column represents any package in the third column. Hovering over the arrows in the depchains column with your cursor will show the dependency that led from one package in the chain to the next.

The output is first grouped by the shared unsatisfied dependency (last column) and then by shared dependency chain (fourth column). The groups are sorted by the number of packages missing the dependency in the last column. Within each group, the output is sorted by the number of packages sharing the same dependency chain.

# of packages per missing# of packages per depchainpackages with missing (possibly transitive) dependenciesDepchainsUnsatisfied dependency
52 24cairo-dock-dbus-plug-in-interface-mono cowbell gbrainy gnome-subtitles gtk-sharp2-gapi gtk-sharp3-gapi libappindicator3-0.1-cil libatk3.0-cil libayatana-appindicator0.1-cil libcairo1.10-cil libgdcm-cil libgdk3.0-cil libgio3.0-cil libglade2.0-cil libglib2.0-cil libglib3.0-cil libgpod-cil (O: #867215) libgtk-dotnet3.0-cil libgtk2.0-cil libgtk3.0-cil libmono-fuse-cil libpango3.0-cil libsbml5-cil libvtkgdcm-cil(*) libmono-corlib4.5-cil:armhf (>= 5.18.0.240)
6cairo-dock-dbus-plug-in-interface-mono cowbell libayatana-appindicator0.1-cil libglade2.0-cil libgpod-cil (O: #867215) tangerine(*)libglib2.0-cil
5cowbell libayatana-appindicator0.1-cil libglade2.0-cil libgpod-cil (O: #867215) tangerine(*)libgtk2.0-cil
2cowbell tangerine(*)libglade2.0-cil
2libglib2.0-cil-dev libgtk2.0-cil(*)libglib2.0-cil
1gtk-sharp2-gapi(*)libglib2.0-cil
1libayatana-appindicator0.1-cil-dev(*)libayatana-appindicator0.1-cillibglib2.0-cil
1libayatana-appindicator0.1-cil-dev(*)libayatana-appindicator0.1-cillibgtk2.0-cil
1libglade2.0-cil-dev(*)libglade2.0-cillibglib2.0-cil
1libglade2.0-cil-dev(*)libglade2.0-cil
1libglade2.0-cil-dev(*)libgtk2.0-cil-devlibgtk2.0-cil
1libgpod-cil-dev (O: #867215)(*)libgpod-cil (O: #867215)libglib2.0-cil
1libgpod-cil-dev (O: #867215)(*)libgtk2.0-cil-devlibgtk2.0-cil
1libgtk2.0-cil-dev(*)libglib2.0-cil-devlibglib2.0-cil
1libgtk2.0-cil-dev(*)libgtk2.0-cil
1tangerine-dbg(*)tangerinelibglade2.0-cil
1tangerine-dbg(*)tangerinelibglib2.0-cil
1tangerine-dbg(*)tangerinelibgtk2.0-cil
31 6cairo-dock-dbus-plug-in-interface-mono cowbell libayatana-appindicator0.1-cil libglade2.0-cil libgpod-cil (O: #867215) tangerine(*)libglib2.0-cil cli-common:armhf (>= 0.5.6)
5cowbell libayatana-appindicator0.1-cil libglade2.0-cil libgpod-cil (O: #867215) tangerine(*)libgtk2.0-cil
3libglade2.0-cil libglib2.0-cil libgtk2.0-cil(*)
2cowbell tangerine(*)libglade2.0-cil
2libglib2.0-cil-dev libgtk2.0-cil(*)libglib2.0-cil
1gtk-sharp2-gapi(*)libglib2.0-cil
1libayatana-appindicator0.1-cil-dev(*)libayatana-appindicator0.1-cillibglib2.0-cil
1libayatana-appindicator0.1-cil-dev(*)libayatana-appindicator0.1-cillibgtk2.0-cil
1libglade2.0-cil-dev(*)libglade2.0-cil
1libglade2.0-cil-dev(*)libglade2.0-cillibglib2.0-cil
1libglade2.0-cil-dev(*)libgtk2.0-cil-devlibgtk2.0-cil
1libgpod-cil-dev (O: #867215)(*)libgpod-cil (O: #867215)libglib2.0-cil
1libgpod-cil-dev (O: #867215)(*)libgtk2.0-cil-devlibgtk2.0-cil
1libgtk2.0-cil-dev(*)libglib2.0-cil-devlibglib2.0-cil
1libgtk2.0-cil-dev(*)libgtk2.0-cil
1tangerine-dbg(*)tangerinelibglade2.0-cil
1tangerine-dbg(*)tangerinelibglib2.0-cil
1tangerine-dbg(*)tangerinelibgtk2.0-cil
21 7cowbell gbrainy gnome-subtitles gtk-sharp3-gapi libgio3.0-cil libglib2.0-cil libmono-fuse-cil(*) libmono-system4.0-cil:armhf (>= 5.18.0.240)
6cairo-dock-dbus-plug-in-interface-mono cowbell libayatana-appindicator0.1-cil libglade2.0-cil libgpod-cil (O: #867215) tangerine(*)libglib2.0-cil
2libglib2.0-cil-dev libgtk2.0-cil(*)libglib2.0-cil
1gtk-sharp2-gapi(*)libglib2.0-cil
1libayatana-appindicator0.1-cil-dev(*)libayatana-appindicator0.1-cillibglib2.0-cil
1libglade2.0-cil-dev(*)libglade2.0-cillibglib2.0-cil
1libgpod-cil-dev (O: #867215)(*)libgpod-cil (O: #867215)libglib2.0-cil
1libgtk2.0-cil-dev(*)libglib2.0-cil-devlibglib2.0-cil
1tangerine-dbg(*)tangerinelibglib2.0-cil
12 5cowbell libayatana-appindicator0.1-cil libglade2.0-cil libgpod-cil (O: #867215) tangerine(*)libgtk2.0-cil libmono-system-drawing4.0-cil:armhf (>= 5.12.0.309)
2libgtk-dotnet3.0-cil libgtk2.0-cil(*)
1libayatana-appindicator0.1-cil-dev(*)libayatana-appindicator0.1-cillibgtk2.0-cil
1libglade2.0-cil-dev(*)libgtk2.0-cil-devlibgtk2.0-cil
1libgpod-cil-dev (O: #867215)(*)libgtk2.0-cil-devlibgtk2.0-cil
1libgtk2.0-cil-dev(*)libgtk2.0-cil
1tangerine-dbg(*)tangerinelibgtk2.0-cil
11 5cowbell libayatana-appindicator0.1-cil libglade2.0-cil libgpod-cil (O: #867215) tangerine(*)libgtk2.0-cil libmono-cairo4.0-cil:armhf (>= 5.16.0.220)
1libayatana-appindicator0.1-cil-dev(*)libayatana-appindicator0.1-cillibgtk2.0-cil
1libglade2.0-cil-dev(*)libgtk2.0-cil-devlibgtk2.0-cil
1libgpod-cil-dev (O: #867215)(*)libgtk2.0-cil-devlibgtk2.0-cil
1libgtk2.0-cil(*)
1libgtk2.0-cil-dev(*)libgtk2.0-cil
1tangerine-dbg(*)tangerinelibgtk2.0-cil
6 6cowbell gbrainy gtk-sharp2-gapi gtk-sharp3-gapi quickroute-gps tangerine(*) libmono-system-xml4.0-cil:armhf (>= 4.6.1.3)
6 6cowbell gbrainy gtk-sharp2-gapi gtk-sharp3-gapi quickroute-gps tangerine(*)mono-runtimemono-runtime-sgenmono-runtime-common mono-gac:armhf (= 6.8.0.105+dfsg-3)
5 5gtk-sharp2-gapi gtk-sharp3-gapi libxml-libxslt-perl os-autoinst sympa(*)libxml-libxml-perl libxml-namespacesupport-perl:armhf
5 5gtk-sharp2-gapi gtk-sharp3-gapi libxml-libxslt-perl os-autoinst sympa(*)libxml-libxml-perl libxml-sax-perl:armhf
5 5gtk-sharp2-gapi gtk-sharp3-gapi libxml-libxslt-perl os-autoinst sympa(*)libxml-libxml-perl perlapi-5.32.0:armhf
2 2gtk-sharp2-gapi gtk-sharp3-gapi(*)libxml-libxml-perlperl perl-base:armhf (= 5.32.1-3)

generated: 20210405T000000Z


The JSON data used to generate these pages was computed using botch, the bootstrap/build ordering tool chain. The source code of botch can be redistributed under the terms of the LGPL3+ with an OCaml linking exception. The source code can be retrieved from https://gitlab.mister-muffin.de/debian-bootstrap/botch

The html pages were generated by code which can be retrieved from https://gitlab.mister-muffin.de/debian-bootstrap/bootstrap_debian_net and which can be redistributed under the terms of the AGPL3+

For questions and bugreports please contact j [dot] schauer [at] email [dot] de.