Below are two tables showing the two problem classes that prevent installation of foreign architecture binaries

We try to install all binary packages from a dummy architecture generated from amd64 (called armhf here) on amd64.

A machine parsable version can be retrieved in dose yaml format

Hover over a package name with your cursor for architecture and version information. Hovering over the arrows in the depchain columns will show the dependency that led from one package in the chain to the next.

src:boost-defaults

Top 10 summary

The following is a summary of the full "missing" and "conflict" tables below. It only shows the first and last columns of the full tables and only displays the top 10 rows.

Conflict

# of packages per conflictConflict
20libpsm-infinipath1:armhf
20libpsm2-2:amd64
17libfabric1:amd64
3libfabric1:armhf

conflict

The packages in the third column cannot satisfy their (possibly transitive) dependencies because the last package(s) in the first depchain have an unsatisfied conflict which is shown in the last column. The second depchain column shows the dependency chain(s) to the package which the last package(s) in the first depchain conflict with. Sometimes, multiple dependency chains sharing the same conflict exist. Hovering over the arrows in the depchains column with your cursor will show the dependency that led from one package in the chain to the next.

The output is first grouped by the shared conflicting dependency (last column) and then by the shared dependency chains (fourth and fifth column). The groups are sorted by the number of packages sharing the conflict in the last column. Within each group, the output is sorted by the number of packages sharing the same dependency chains.

# of packages per conflict# of packages per depchainpackages with (possibly transitive) conflicting dependenciesDepchain 1Depchain2Conflict
20 10libdart-collision-bullet-dev libdart-collision-ode-dev libdart-external-ikfast-dev libdart-external-imgui-dev libdart-external-lodepng-dev libdart-gui-dev libdart-optimizer-nlopt-dev libdart-utils-dev libdart-utils-urdf-dev libgazebo-dev(*)libdart-devlibboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm-infinipath1(*)libdart-devlibboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm-infinipath1 libpsm-infinipath1:armhf
2libboost-mpi-dev libboost1.74-all-dev(*)libboost-mpi1.74-devlibboost-mpi1.74.0libopenmpi3libpsm-infinipath1(*)libboost-mpi1.74-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libpsm-infinipath1
2libdart-dev liborthancframework-dev(*)libboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm-infinipath1(*)libboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm-infinipath1
2libui-gxmlcpp-dev libui-utilcpp-dev(*)libboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm-infinipath1(*)libboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm-infinipath1
1libboost-all-dev(*)libboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm-infinipath1(*)libboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm-infinipath1
1libboost-mpi-python-dev(*)libboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm-infinipath1(*)libboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm-infinipath1
1libdart-gui-osg-dev(*)libdart-gui-devlibdart-devlibboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm-infinipath1(*)libdart-gui-devlibdart-devlibboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm-infinipath1
1libdolfinx-dev(*)libboost-mpi-devlibboost-mpi1.74-devlibboost-mpi1.74.0libopenmpi3libpsm-infinipath1(*)libhdf5-mpi-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libpsm-infinipath1
20 10libdart-collision-bullet-dev libdart-collision-ode-dev libdart-external-ikfast-dev libdart-external-imgui-dev libdart-external-lodepng-dev libdart-gui-dev libdart-optimizer-nlopt-dev libdart-utils-dev libdart-utils-urdf-dev libgazebo-dev(*)libdart-devlibboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm2-2(*)libdart-devlibboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm2-2 libpsm2-2:amd64
2libboost-mpi-dev libboost1.74-all-dev(*)libboost-mpi1.74-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libpsm2-2(*)libboost-mpi1.74-devlibboost-mpi1.74.0libopenmpi3libpsm2-2
2libdart-dev liborthancframework-dev(*)libboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm2-2(*)libboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm2-2
2libui-gxmlcpp-dev libui-utilcpp-dev(*)libboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm2-2(*)libboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm2-2
1libboost-all-dev(*)libboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm2-2(*)libboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm2-2
1libboost-mpi-python-dev(*)libboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm2-2(*)libboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm2-2
1libdart-gui-osg-dev(*)libdart-gui-devlibdart-devlibboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libpsm2-2(*)libdart-gui-devlibdart-devlibboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libpsm2-2
1libdolfinx-dev(*)libhdf5-mpi-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libpsm2-2(*)libboost-mpi-devlibboost-mpi1.74-devlibboost-mpi1.74.0libopenmpi3libpsm2-2
17 9libdart-collision-bullet-dev libdart-collision-ode-dev libdart-external-ikfast-dev libdart-external-imgui-dev libdart-external-lodepng-dev libdart-gui-dev libdart-optimizer-nlopt-dev libdart-utils-dev libdart-utils-urdf-dev(*)libdart-devlibboost-all-devlibboost-mpi-devlibboost-mpi1.74-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libfabric1(*)libdart-devlibboost-all-devlibboost-graph-parallel-devlibboost-graph-parallel1.74-devlibboost-graph-parallel1.74.0libopenmpi3libfabric1 libfabric1:amd64
2libui-gxmlcpp-dev libui-utilcpp-dev(*)libboost-all-devlibboost-mpi-devlibboost-mpi1.74-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libfabric1(*)libboost-all-devlibboost-graph-parallel-devlibboost-graph-parallel1.74-devlibboost-graph-parallel1.74.0libopenmpi3libfabric1
1libboost-all-dev(*)libboost-mpi-devlibboost-mpi1.74-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libfabric1(*)libboost-graph-parallel-devlibboost-graph-parallel1.74-devlibboost-graph-parallel1.74.0libopenmpi3libfabric1
1libboost-mpi-dev(*)libboost-mpi1.74-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libfabric1(*)libboost-mpi1.74-devlibboost-mpi1.74.0libopenmpi3libfabric1
1libboost-mpi-python-dev(*)libboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libfabric1(*)libboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libfabric1
1libdart-all-dev(*)libdart-planning-devlibflann-devlibhdf5-mpi-devlibhdf5-openmpi-devlibopenmpi-devopenmpi-binlibopenmpi3libfabric1(*)libdart-devlibboost-all-devlibboost-graph-parallel-devlibboost-graph-parallel1.74-devlibboost-graph-parallel1.74.0libopenmpi3libfabric1
1libdart-dev(*)libboost-all-devlibboost-mpi-devlibboost-mpi1.74-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libfabric1(*)libboost-all-devlibboost-graph-parallel-devlibboost-graph-parallel1.74-devlibboost-graph-parallel1.74.0libopenmpi3libfabric1
1libdart-gui-osg-dev(*)libdart-gui-devlibdart-devlibboost-all-devlibboost-mpi-devlibboost-mpi1.74-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libfabric1(*)libdart-gui-devlibdart-devlibboost-all-devlibboost-graph-parallel-devlibboost-graph-parallel1.74-devlibboost-graph-parallel1.74.0libopenmpi3libfabric1
3 1libdolfinx-dev(*)libboost-mpi-devlibboost-mpi1.74-devlibboost-mpi1.74.0libopenmpi3libfabric1(*)libhdf5-mpi-devmpi-default-devlibopenmpi-devopenmpi-binlibopenmpi3libfabric1 libfabric1:armhf
1libgazebo-dev(*)libdart-devlibboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libfabric1(*)libdart-devlibboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libfabric1
1liborthancframework-dev(*)libboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0libopenmpi3libfabric1(*)libboost-all-devlibboost-mpi-python-devlibboost-mpi-python1.74-devlibboost-mpi-python1.74.0mpi-default-binopenmpi-binlibopenmpi3libfabric1

generated: 20211129T000000Z


The JSON data used to generate these pages was computed using botch, the bootstrap/build ordering tool chain. The source code of botch can be redistributed under the terms of the LGPL3+ with an OCaml linking exception. The source code can be retrieved from https://gitlab.mister-muffin.de/debian-bootstrap/botch

The html pages were generated by code which can be retrieved from https://gitlab.mister-muffin.de/debian-bootstrap/bootstrap_debian_net and which can be redistributed under the terms of the AGPL3+

For questions and bugreports please contact j [dot] schauer [at] email [dot] de.